Indexing issues - For the pros

Discussion in 'General Advice' started by aldanson, May 2, 2011.

  1. aldanson

    aldanson New Member

    I just created a new wordpress site but I didn't install it in the root folder I created a directory within my ftp and installed it that way. I created my index page in the root folder but now Google won't index anything inside the wordpress folder.

    Did I do something wrong here? My index page is indexed.
     
  2. Just2EZ

    Just2EZ Moderator

    Try using the WP plug in "Google XML Sitemaps", it will index the whole site.
    It may just be the permission settings you have on the WP folder.
    I have several WP sites as sub-directories of the main HTML site.
    Google has no problem with you doing it that way.
     
  3. aldanson

    aldanson New Member

    interesting. I have everything set up and the sitemap all done up with the plug in. I have 10 sites up but this one is giving me issues. I will monitor it I guess. Thanks for the response. Any other ideas would be great.
     
  4. Just2EZ

    Just2EZ Moderator

    Another thing to check would be the htaccess file on the WP directories.
    It may be set to -indexes or disallowed altogether.
    The WP plug in needs folder permissions set to 755 to work properly,
    otherwise it can't read the folders and write the index.
    Any luck? It may take Google a few days to get over being "denied".
    Once they hit that 403 a few times they wait before trying again.
     
  5. katereber

    katereber New Member

    Just2EZ: Another thing to check would be the htaccess file on the WP directories.
    It may be set to -indexes or disallowed altogether.
    The WP plug in needs folder permissions set to 755 to work properly,
    otherwise it can't read the folders and write the index.
    Any luck? It may take Google a few days to get over being "denied".
    Once they hit that 403 a few times they wait before trying again.
    Great information friend..
     
  6. aldanson

    aldanson New Member

    So I rebuilt the sitmap and now Google recognizes it in Google Webmaster Tools. I also built a robots.txt file which seems to be working. I looked at the htaccess file but I don't know what I am looking for.

    The odd thing about this is that my website squeeze page (http://mysit.com) that I created in Dreamweaver shows up on Googles list but the wordpress in a directory (http://mysite.com/directory) is not recognized by Google at all.

    I must have done something wrong. I am thinking I should delete it all and start fresh. Any more ideas?
     
  7. Just2EZ

    Just2EZ Moderator

    Just2EZ: Another thing to check would be the htaccess file on the WP directories.
    It may be set to -indexes or disallowed altogether
    That was the main thing to check htaccess for but also how many copies where?
    If you use a FTP client, look in each folder that is not indexing for an htaccess file.
    Their may be another copy that's blocking access to that directory.
    For a quick guide to htaccess tricks for WP check this site out:
    http://wpshout.com/a-to-z-of-wordpress-htaccess-hacks/
    I assume this was before the robots.txt was installed? if not, robot.bad
     

Share This Page